Перейти к публикации
СофтФорум - всё о компьютерах и не только
__alex

Инет и ХР

Рекомендованные сообщения

Вобщем такой расклад. К инету я подключаюсь по диалапу, и все было нормально до тех пор пока я ни снес 2000й виндовс и поставил вместо него ХР. А тут получается интересная вещь - дозваниваться до провайдера проблемы не составляет, зато потом невозможно работать - браузер на попытку пойти туда-то пишет что страница недоступна. Пойти на какой нить сайт можно только одним способом - набирать его айпишник вручную. Очень удобно :) память развивает :) Жаль только что айпишник только с другого компа получать надо...

Короче не пойму че стряслось :) WindowsXP SP1, все службы которые по-умолчанию грузятся - есть, система ваще считай чистая, ниче я там не творил еще. Помогите пожалуйста.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1.А какой у тебя бровзер?

2.Посмотри политики, авось что не так стоит.

3.Если комп у тебя новый и это ты первый раз переставил винду то скорей всего подходит пункт 2, если нет то посмотри может что от Вин 2k exporer`у осталось вот оно и глючит.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А причем тут вообще ативирус???

Тогда уж фаервол запрещает...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1.А какой у тебя бровзер?

2.Посмотри политики, авось что не так стоит.

3.Если комп у тебя новый и это ты первый раз переставил винду то скорей всего подходит пункт 2, если нет то посмотри может что от Вин 2k exporer`у осталось вот оно и глючит.

1. Какой браузер - значения не имеет, поверь. Тут глубже копать надо, че то с днс не то...

2. Ну че там не то? Говорю же - система новая, в политиках я пока только автозапуск отключил :D В разделе сети все политики еще не заданы.

3. От видны2к и полбайта не осталось ;) Перестановка проходила стерильно чисто - удалаем системный раздел с видной2к, создаем заново и туда уже ставим новую... Да еще и программные файлы затираем нафиг. Но настройки конечно глядел и не один раз - все вроде гуд..

Насчет антивирей и файрволов - ниче такого нету. Стандартный файрвол винды для данного соединения я не использую, да и его (файрвола) служба не запущена.

Сервис пак как уже было сказано - всего первый.

Проблема то в чем - не вообще в инет не могу выйти, а из адреса типа yande.ru получить его айпишник; если же вводить айпишник вручную то все пашет!

И где долбаные грабли?..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

После того что ты написал остаётся только вариант что АТС тормозит :D

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

__alex

Совет не-столь вУмный, но сделай проще, ведь ты только что установил ОС, так -так, значить переустановить проблем нету?

Переустанови, возможно косо встала.

------------------------

Или попробуй поставь Оперу, и с нее попробуй выход в инет.

Или все таки файворл работает.

Или ОС ХР хоме, и такое бывает.

Все ИМХО. :D

Просто так глюков быть неможет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Zloi_Maniak

После того что ты написал остаётся только вариант что АТС тормозит

Да она по жизни тормозит, не в этом вопрос :punk:

legos

Совет не-столь вУмный, но сделай проще, ведь ты только что установил ОС, так -так, значить переустановить проблем нету?

Переустанови, возможно косо встала.

Не хочу :) Это не есть решение проблемы, встала ось нормально, так зачем лишние телодвижения?

Или попробуй поставь Оперу, и с нее попробуй выход в инет.

Да хоть в ИЕ, хоть в опере, хоть ping-ом... Один черт..

Или все таки файворл работает.

Если ты про службу "Брандмауэр Интернета (ICF) /Общий доступ к Интернету (ICS)", то ниче подобного.

Или ОС ХР хоме, и такое бывает.

Ну уж нет, спасибо, лучше я тогда опять 2000-й поставлю :)

Или ты смысле про то что стоит? Pro стоит.

Все ИМХО. 

Просто так глюков быть неможет?

Не бывает :) Но бывают глюки на ровном месте :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Kuzmich

А причем тут вообще ативирус???

Тогда уж фаервол запрещает...

ты конечно прав. я неточно выразился.у меня например фаер и антивирус совмещены

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не могу помочь, но было тоже: коннектит, но е работает ни броузер, ни почтовые программы. Причем тоже бывало и в МЕ и в 98 (на нотбуке). Решал перестановкой. Было чувство, что комп просто не видит подключения к нету.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ИМХО, явно что-то с DNS барахлит. Проверь еще раз все записи в настройках про DNS и уточни у прова, посмотри нет ли какого прокси, проверь файл hosts - по чистому там должна быть только одна рабочая строка localhost 127.0.0.1, проверь включена ли служба DNS клиент.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

worker

ИМХО, явно что-то с DNS барахлит. Проверь еще раз все записи в настройках про DNS и уточни у прова, посмотри нет ли какого прокси, проверь файл hosts - по чистому там должна быть только одна рабочая строка localhost 127.0.0.1, проверь включена ли служба DNS клиент.

Вот вот, проклятый днс. В настройках TCP/IP днс должен получаться автоматически. А файл hosts - это че за зверь? Не нашел я такого... В настройках WINS есть про lmhosts, но это ведь не то?

Служба днс-клиент запущена.

Вобщем звякнул я провайдеру и получил пару адресов его днс-серверов. Указал в настройках TCP/IP и инет теперь пашет нормально. Еще один товарисч предложил указать адрес 128.214.46.64 - с ним тоже все работает.

Короче проблема как бы решена. Но. Все равно не понятно - как то же все это раньше работало без прямого указания днс-серверов? Давайте разберемся, интересно же ;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может я и не прав, в теории не силен, но когда ты задаешь адрес в инете, твой комп должен пойти на сервер DNS и там получить IP. Если у компа не был записан IP этого сервера, то ты дальше пройти не сможешь... Ну а дальше варианты - искажение или потеря этого IP при инсталляции, проблемы у провайдера и тот сервер, адрес которого указан, недоступен, ну и дальше в том же духе...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

__alex

Вобщем звякнул я провайдеру и получил пару адресов его днс-серверов. Указал в настройках TCP/IP и инет теперь пашет нормально.

Так и должно было быть. Вероятно, у провайдера при старте ppp криво отдаются адреса DNS. Бывает такое.

Ты эти адреса запомни куда-нибудь, могут еще пригодиться.

А hosts лежит в %systemroot%\system32\drivers\etc\

Отвечает за разрешение доменных адресов в IP. Получился исторически, когда вся Сеть сосотояла из пары десятков машин. Сейчас, насколько знаю, используется для задания статического соответсвия имя-адрес. Помогает, если падает DNS. Еще пригождается при сочетании в сети Linux,Windows,etc когда не удается настроить, например резолв NBname-IP.

В классическом виде его структура очень проста

IP_address host_domain_name

Файл lmhosts это такая же вещь, но для имен NetBIOS, а WINS как раз и есть служба разрешения имен NETBIOS в адрес.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Теперь ясно. Там и правда всего одна строчка:

127.0.0.1 localhost

А файлу почему я сразу не нашел - FAR при поиске *hosts*.* этот файл не нашел ;) Кто бы мог предположить... ;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

×