Jump to content
СофтФорум - всё о компьютерах и не только

Примерно раз в сутки пропадает инет


Darth Emil
 Share

Recommended Posts

Для начала обрисую ситуацию:

Неделю назад наш провайдер повысил скорость доступа к интернету до 512 кбит/с по моему тарифу.

Практически одновременно с этим начались глюки. Периодически, с разным интервалом времени пропадал линк. В саппорте прова извинились, и сказали что тестируют линию и всё такое.

После нескольких звонков в саппорт провайдера мне для теста подняли скорость до 1 мбита. Так скорость и осталась, но линк всё равно пропадал.

Техники от провайдера обнаружили плохой контакт кабеля в розетке. После этого проблема как бы пропала, но через пару дней возникла вновь.

На этот раз было дело в перегреве. Я поставил на модем кулер и линк больше не пропадает.

Но вот уже дня 4-5 появляется такая трабла: как минимум раз в сутки начинает тупить инет:

Аська и майл-агент работают, а вот браузеры, качалка, ослик нет. Сайты пингуются через раз. Торрент то начинает качать, то сбрасывается... Скорость скачет.

При этом линк есть - зелёный диод DSL горит, авторизация есть и обмен данными идёт - оранжевый диод PPP и зелёный USB перемигиваются как обычно. Т.е. инет как бы есть, но его нет.

После выключения и включения модема всё становится нормально, до следующего раза.

Я думал может опять линия глючит, поменял всю телефонную проводку в доме - ничего не изменилось.

Переподключил модем в другой USB-порт - результат тот же.

В чём причина, где копать?

Модем ZyXEL P-660RU, подключен через USB, режим роутера.

Link to comment
Share on other sites

провайдер я так понимаю казахтелеком со своим проектом мегалайн? Тоже уже устал бороться с этим. Когда можем стоял в режиме бридж, вобще конект пропадал постоянно, после перевод в режим роутера связь стала стабильнее, но с такой же завидной стабильностью обрывается раз в сутки, и да, действительно бывает такое, что торент работает, а браузер показывать сайты отказывается.

насколько я понял, это возникает из за того что периодически пропадает Ping primary Domain Name Server. В самом казахтелекоме объясняют это по разному: тестим линию, перегрузки постоянные, сбои в работе сервера. То есть, как я понял, на даный момент бороться с этим бесполезно, пока провайдер не решит все свои проблемы, наши проблемы тоже не решаться.

Link to comment
Share on other sites

Для локализации повреждения можно поменять в связке ПК-модем-линия сначала модем на заведомо рабочий. а потом подключиться другим ПК, желательно оборудование провайдера. Кстати, для проверки они приходили со служебным оборудованием? Это было бы самое простое-модем и ноутбук првайдера. Все вопросы бы были сняты. Можно проверить модем на другой линии и ПК. Тогда можно уже будет копать в одном месте. Что бы не проверять все продряд.

Link to comment
Share on other sites

Кстати, для диагностики, можете попробывать. Для Zyxel-ей в Telnet (24 =>> 8):

poe drop poe0 - сброс PPPoE сесси (попробуй сначала эту команду выполнить, когда начнутся проблемы).

wan adsl reset - сброс ADSL линка.

wan adsl perfdata - отображение ошибок за сеанс ADSL линка.

Пинги и трасы прямо с модема:

ip ping host.com

ip traceroute host.com

Edited by Roader
Link to comment
Share on other sites

Обнаружил ещё такую странную вещь: когда инет отрубается, зайти на него через telnet или в веб-конфигуратор не получается. Для начала переустановил дрова на модем.

Link to comment
Share on other sites

Инет опять отрубился, всё как описано выше. Я модем перезагружать не стал, переустановил дрова. После перезагрузки компа вроде всё нормально было. Через пять минут опять пропал инет. Модем ребутнул - всё ок.

Итак, что глючит: модем или система? Вариант с переустановкой винды рассматривать в последнюю очередь.

Link to comment
Share on other sites

Проверка линии:

P660RU-T1> wan adsl perfdata

near-end FEC error fast: 0

near-end FEC error interleaved: 112

near-end CRC error fast: 0

near-end CRC error interleaved: 0

near-end HEC error fast: 0

near-end HEC error interleaved: 0

far-end FEC error fast: 0

far-end FEC error interleaved: 0

far-end CRC error fast: 0

far-end CRC error interleaved: 0

far-end HEC error fast: 0

far-end HEC error interleaved: 0

ADSL uptime 0:11:07

Пинг:

P660RU-T1> ip ping mail.ru

Resolving mail.ru... 194.67.57.226

sent rcvd rate rtt avg mdev max min

1 1 100 200 200 0 200 200

2 2 100 220 203 5 220 200

3 3 100 280 213 23 280 200

P660RU-T1>

Link to comment
Share on other sites

На счёт линии, хотелось канечно увидеть статистику за как минимум 24 часа. near-end FEC error interleaved: 112 - за 11 минут, практически не отразится на скорости ни как. Эти ошибки корректируемые, патерий пакетов не должно быть. Ещё забыл дописать несколько команд:

wan adsl linedata near - затухание, сигнал/шум, тоны для downstream (входящий поток)

wan adsl linedata far - оно же, только для upstream (исходящий поток)

24 =>> 1 - Постоянно обновляющиеся окно статистики. Что касается ADSL линка, то там справа снизу показываются значения Upstream Speed и Downstream Speed. Они и означают физическую скорость соединения, она должна быть не менее чем на 10% более тарифной. Обычно провайдер принудительно её занижает до таковых значений, для обеспечения большей надёжности DSL соединения и снижения перекрёстных помех в многопарном кабеле (паразитные наводки в многопарном телефонном кабиле в случае работы DSL на соседних парах).

Но по вышеописанным симптомам я не думаю, что проблема в линии, её пока трогать не нужно:

Я модем перезагружать не стал, переустановил дрова. После перезагрузки компа вроде всё нормально было. Через пять минут опять пропал инет. Модем ребутнул - всё ок.

А теперь говорю золотые слова, которые даже здесь на форуме неоднократно повторял: Использовать USB в ачестве эмулятора ethernet - извращенство! Подключи через ethernet! Да и бывает, что USB порт "залипает" при работе с модемами. Ещё одна вещь! Интернет заработал после перезагрузки компьютера (очень сомнительна вина провайдера).

Обнаружил ещё такую странную вещь: когда инет отрубается, зайти на него через telnet или в веб-конфигуратор не получается.
Вот тут уже провайдер 100% не при чём (состояние DSL и PPP никак не влияет на доступность модема с локальных интерфейсов). Когда он будет подключен по ethernet и когда та же проблема возникнет вновь (если она возникнет), попробуй зайти в него через Web, Telnet и попинговать модем. Edited by Roader
Link to comment
Share on other sites

Roader: я тоже склонялся к мысли подключить через ethernet. Завтра сделаю, вот только одно хочется понять: с ЧЕГО такие глюки начались и как их исправить? И самое что странное - каждые сутки поздно вечером или ночью такая фигня. А всё остальное время работает как часы...

Ещё одно: у друга такой же модем, также подключен через USB, но при этом в режиме бриджа - и такая же проблема... совпадение?

Интернет заработал после перезагрузки компьютера (очень сомнительна вина провайдера).
Да, но пропал через несколько минут.

ЗЫ: Так, я подключу модем через сетевуху, настраивать вроде ничего не надо? В настройках сетевухи указать получение адреса через DHCP?

Edited by Darth Emil
Link to comment
Share on other sites

ЗЫ: Так, я подключу модем через сетевуху, настраивать вроде ничего не надо? В настройках сетевухи указать получение адреса через DHCP?

Если не отключал DHCP сервер на модеме, то можно и по DHCP. Но я не советую, хотя бы по той причине, что отклик DHCP сервера на широковещательный запрос IP адреса сетевухой компа будет длиться 10-15 сек... Ну так на этом модеме "тормознуто" работает DHCP сервер. По этому, дабы не ждать после загрузки некоторое время лучше прописать вручную. К примеру, если IP модема 192.168.1.1

IP_mod.jpg

post-29300-1213047772_thumb.jpg

Link to comment
Share on other sites

DoctorG: как давно у тебя схожая проблема? Какой модем?

Да вот, второй месяц уже, достало немеряно, поставишь так что нить, на скачку, уйдешь сутра на учебу, думаешь вечером прийдешь, скачалось все, а не тут то было, связь разорвана инета нет.

Модем TP-link TD8811(A) подключен через ethernet работает в режиме роутера. Симптомы болезни абсолютно точно такие же как и у тебя, после процедуры включить\выключить все работает. Только вот как, может работать нормально в течении суток, а может связь через 10 минут оборвется и снова надо будет повторять процедуру.

Link to comment
Share on other sites

Подключил через Ethernet, жду...

Вот логи:

P660RU-T1> wan adsl linedata near

noise margin downstream: 25 db

output power upstream: 12 db

attenuation downstream: 34 db

carrier load: number of bits per symbol(tone)

tone 0- 31: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 32- 63: 00 00 00 00 00 00 00 33 44 45 45 55 55 66 66 65

tone 64- 95: 56 56 66 66 65 66 66 66 66 66 55 66 56 64 55 55

tone 96-127: 50 55 54 44 44 44 44 23 33 33 33 30 33 33 22 10

tone 128-159: 01 22 22 33 33 43 33 32 20 00 00 00 01 11 11 11

tone 160-191: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 192-223: 00 00 00 00 00 00 00 00 00 11 11 11 10 00 00 00

tone 224-255: 00 00 01 22 22 21 00 00 00 00 00 11 22 21 11 10

tone 256-287: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 288-319: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 320-351: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 352-383: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 384-415: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 416-447: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 448-479: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 480-511: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

P660RU-T1> wan adsl linedata far

noise margin upstream: 22 db

output power downstream: 1 db

attenuation upstream: 21 db

carrier load: number of bits per symbol(tone)

tone 0- 31: 00 00 00 23 55 67 88 88 88 88 88 88 77 66 54 32

tone 32- 63: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 64- 95: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 96-127: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 128-159: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 160-191: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 192-223: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 224-255: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 256-287: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 288-319: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 320-351: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 352-383: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 384-415: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 416-447: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 448-479: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

tone 480-511: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Link to comment
Share on other sites

Подключил через Ethernet.

Но я не советую, хотя бы по той причине, что отклик DHCP сервера на широковещательный запрос IP адреса сетевухой компа будет длиться 10-15 сек... Ну так на этом модеме "тормознуто" работает DHCP сервер. По этому, дабы не ждать после загрузки некоторое время лучше прописать вручную.
Прописал 192.168.1.1 - модем матюгнулся что это его собственный ip. Поставил 192.168.1.2 - перестал работать ослик и торрент. Поставил 192.168.1.33 - работает, но у меня сомнения насчёт DNS - когда я подключал через USB то там в качестве певичного DNS автоматом указывался ip адрес модема, вот только я забыл что именно там ставится: 192.168.1.1 или 192.168.1.33 :1eye:

Screen.JPG

post-13165-1213097029_thumb.jpg

Link to comment
Share on other sites

Darth Emil

256263.jpg

А вторичный вобще не надо указывать.

То есть, как я понял по твоему скрину, у тебя главный DNS стоит как вторичный. поставь его на первое место.

Edited by DoctorG
Link to comment
Share on other sites

Darth Emil, возможно с ip 192.168.1.2 не заработало так как в модеме не включена опция "any ip" в LAN. Ну да ладно, начиная с 33-го адреса должно работать.

На счёт DNS, вообще должен быть прописан один предпочитаемый DNS сервер - IP модема 192.168.1.1 (как у меня на скрине). Та как модем работает роутером, то он сам подымает DNS прокси. Вписывать вручную DNS я не советую, исключение, если только это требует провайдер (но на сегодняшний день такое очень редко). Завтра провайдер в полном праве будет сменить IP адреса DNS серверов и в случае, если в качестве первичного DNS будет прописанный вручную IP провайдера, то минимум получим лишние задержки в его работе (пока запрос не повторится по 192.168.1.1).

Кстати, просмотр состояния DNS и подхваченные IP адреса первичного, вторичного и активного для Zyxel ip dns stats disp

...Симптомы болезни абсолютно точно такие же как и у тебя, после процедуры включить\выключить все работает. Только вот как, может работать нормально в течении суток, а может связь через 10 минут оборвется и снова надо будет повторять процедуру.

Честно говоря, если вы такое скажете саппорту провайдера, то вполне можете получить ответ "а в чём наша вина, что после ребута модема у вас всё нормально начинает работать" и частично они будут правы. Мало того, если заикнётесь про роутер, то опять с большой вероятностью вам ответят "Вы уверены, что на вашей стороне всё правильно настроено?".

Вообще, как я выше уже писал, при постоянно повторяющихся подобных симптомах, необходимо произвести простейшие тесты на "своей" стороне: Проверка пингов с роутера, проверка DNS с роутера, сброс PPP, диагностика линии, диагностика нормальной работы самого модема (в первую очередь не виснет ли он). К примеру, попадался мне модем, который работая роутером, через некоторое время обезбашенно рвал активные соединения. То есть интернет кабы есть, но в среднем любое соединение рвалось в интервале от нескольких сек до получаса (аська это плохо переживала). К примеру, включаю интернет радио и работает оно от 10 сек до 30 минут и глохнет.

Вот когда будет достаточное "вооружение" информации и точно будет ясно, что виновен провайдер, то тогда смело можно звонить в саппорт.

Для примера, на вопрос "Попробуйте перезапустить модем", вы смело отвечаете "Проблема повторяется циклически и решается пере подключением PPPoE и проявляется когда модем работает, как и роутером, так и мостом. Суть проблемы - через некотрое время перестают ходить пакеты по всем направлениям, но при этом DNS сервера нормально пингуются и отвечают на запросы".

P.S. Кстати, ещё один момент о котором я сразу подумал по названию топика. Очень многие провайдеры ограничивают максимальную продолжительность PPPoE сессии 24-мя часами. В идеале, после того как прошло 24 часа после подключения, сессия рвётся со стороны провайдера, но при этом роутер её сразу переподключает. Но при этом, соответственно, все активные соединения рвутся.

Edited by Roader
Link to comment
Share on other sites

Честно говоря, если вы такое скажете саппорту провайдера, то вполне можете получить ответ "а в чём наша вина, что после ребута модема у вас всё нормально начинает работать" и частично они будут правы. Мало того, если заикнётесь про роутер, то опять с большой вероятностью вам ответят "Вы уверены, что на вашей стороне всё правильно настроено?".
Узнаю нашего прова :1eye:

P.S. Кстати, ещё один момент о котором я сразу подумал по названию топика. Очень многие провайдеры ограничивают максимальную продолжительность PPPoE сессии 24-мя часами. В идеале, после того как прошло 24 часа после подключения, сессия рвётся со стороны провайдера, но при этом роутер её сразу переподключает. Но при этом, соответственно, все активные соединения рвутся.

А вот эта проблема уже давно воспета Антоном Уральским :1eye: У нас такого нет.
Link to comment
Share on other sites

если только это требует провайдер

Именно этого он и требует.

На счет правильности настроек: Работало ведь все больше чем 6 месяцев уже.

Edited by DoctorG
Link to comment
Share on other sites

Итак, при подключении через Ethernet вроде работает всё нормально. Если что изменится - отпишусь.

ЗЫ: И всё-таки, почему через USB не работает?

Link to comment
Share on other sites

Вчера вечером в 17 или 18 часов снова пропал инет, я подумал что это из-за окончания сессии, модем ребутнул и всё нормально. Сегодня в 18 часов инет снова пропал. Проблема опять вернулась? На городском форуме я поднял этот вопрос, как минимум у 5 людей такая же трабла. Модемы и типы соединений разные... Значит пров? Завтра пойду с ними разбираться...

На форуме ZyXEL посоветовали уменьшить размер MTU, но я не уверен что это что-то даст... Можно его изменить не через терминал, а через веб-конфигуратор?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...