Jump to content
СофтФорум - всё о компьютерах и не только

Recommended Posts

всем доброе утро. с помощью rsync делаю резервное копирование баз данных с другого копьютера в локальной сети. Подключаюсь нормально, что с сервера к своему компу, с со своего к серверу. копирование тоже происходит нормально. Одно но, каждый раз запрашивается пароль. пробовал так

RSYNC_PASSWORD=<пароль>export RSYNC_PASSWORD=<пароль>rsync -auz root@<ip>:/home/vv/Desktop/newcripts/scripts/Admintool /home/user/Desktop/

все равно просят ввести пароль. пробовал по-другому

rsync -avuz --password-file=/home/user/Desktop/2.conf root@<ip>:/home/vv/Desktop/newcripts/scripts/Admintool /home/user/Desktop/ \

/home/user/Desktop/2.conf это файл с единственной строкой, в которой написан пароль

Link to comment
Share on other sites

у меня CentOS 5,4 на сервере старенькая CentOS. как сделать, чтоб не было запроса пароля? а то поставлю копирование баз на 2 часа ночи, придется со свечкой стоять =)))

Link to comment
Share on other sites

решил проблему. копирование было через ssh

This option does not supply a password to a remote shell transport such as ssh; to learn how to do that, consult the remote shell's

documentation. When accessing an rsync daemon using a remote shell as the transport, this option only comes into effect after the

remote shell finishes its authentication (i.e. if you have also specified a password in the daemon's config file).

в этом случае помогла статья

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...